147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-02-15 Thread Starter
Status: -
Join Date: Oct 2012
Location: New Zealand
County: Canterbury
Posts: 2

Member car:

147 selespeed


Hi Guys
Just joined up here , Can anyone tell me why my 147 Selespeed wouldnt go into gear this afternoon .I live in New Zealand and it was 42 deg would the heat do anything to it? and my VDC warning light comes on would very low break pads make the light come on .As you can read im no mechanic ,cheers
welshe is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,990
Originally Posted by welshe View Post
and my VDC warning light comes on, would very low brake pads make the light come on.

Low battery could though, which could also effect the Selespeed system.

Not much info to go on though.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome