New clutch vdc - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-01-15 Thread Starter
Status: -
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: West Yorkshire
Posts: 176
New clutch vdc

Hi all

Had a new clutch fitted on Friday. When I pull away I get a judder and am now also getting VDC error about 10 minutes into my drive.

I am going to take the car back to the garage but I just wondered if anyone could shed a little light why it is doing this .


daryl is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2013
Location: United Kingdom
County: Leicestershire
Posts: 17

Member car:

'04 147 JTD 16v

Can't help you on the clutch judder, mine actually has the same. Judder doesn't come in if I hold the revs higher though. It's always had this since I bought the car (at 93k, now on 120k) but I recently had to get a new clutch + DMF and I thought it would be solved through this, but it wasn't unfortunately.

I had VDC errors 10 mins into my drives for a while too and just ignored it. However I recently had new tyres on the front and wheel alignment sorted at the same time because it was wearing horrifically on the outside of the tyres and since then (~1500 miles ago) I've had no VDC errors.

The VDC system is reliant on wheel speed sensors and if you're alignment is bad enough to give bad data from the sensors I think it will disable VDC to prevent ABS or traction control kicking in at the wrong times.

Anyway I'm keen to follow the clutch judder issue because mine has the same. Mine's also very viby and gearchanges are notchy, wondering if engine mounts are worn?
drewby89 is offline  
Status: -
AO Member
Join Date: Jul 2011
Location: Macedonia, The Former Yug
County: -
Posts: 562
If you changed the DMF, other thing to consider is injectors.

I have the same situation and I am waiting to see what is going to brake first so I can know what was the real reason for juddering in neutral and take off.
Toso is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , vdc

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome