Alfa GT MAF ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 26-01-15 Thread Starter
Status: -
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: West Yorkshire
Posts: 176
Alfa GT MAF ?

Afternoon all

I've been having some issues with my car where it won't start first time, mostly take a goof few cranks of the engine.

I had a new clutch fitted on Friday and the also cleaned the EGR and Manifold but it still struggles to start.

Would I be right in thinking that the MAF sensor could be dirty and stopping it firing up first time?

daryl is offline  
Sponsored Links
Status: Rupert Gaylord Egger of Eggington Hall
AO Gold Member
rugbymike7's Avatar
Join Date: Jan 2014
Location: United Kingdom
County: Hampshire
Posts: 6,919
Doubt it's the maf as you can start the car with that disconnected. More than likely the battery. The cold kills off weak batteries. How old is yours? Pop into your local Halfords for a battery test it's free.
rugbymike7 is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,618
Give the arm that operates the throttlebody a wiggle, make sure it hasn't stuck closed.
Pud237 is offline  
Status: -
AO Member
Join Date: Apr 2011
Location: United Kingdom
County: Lincolnshire
Posts: 741

Member car:

GT 1.9jtd

i presume we are talking a derv GT ? if its not cranking fast enough then it wont start as quick as it shud , as already said , get the battery health checked before you try anything else , if thats ok then the glow plugs could need renewing
bembo449 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , maf

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome