Sad day has come BUT i need advice please gents! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 25-01-15 Thread Starter
Status: -
Join Date: Feb 2014
Location: United Kingdom
County: Kent
Posts: 2
Sad day has come BUT i need advice please gents!

Hiya I have a 2001 147 2 litre selespeed. Lately when the engine gets up to temperature the gearbox decides to miss third and forth gear and hesitate into fifth although not every time, just most. I have decided it is time to part ways with it as I need something abit more family and petrol friendly

I was wondering if this a common issue and had an easy fix or it is time for the scrap yard? If not easily and cheaply fixable what would you expect it to go for? There is also both airbag lights showing on the dash from when the passenger seat was removed.

Hope posting this hear hasn't offended anyone.

dommy147 is offline  
Sponsored Links
Status: -
AO Member
Daytona's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Greater London
Posts: 744
Could be gearbox - this happened to me - 1000

Or possibly gear select actuator - Also 1000 as I recall

Daytona is offline  
(Post Link) post #3 of 7 Old 25-01-15 Thread Starter
Status: -
Join Date: Feb 2014
Location: United Kingdom
County: Kent
Posts: 2
hmmmm doesn't look overly great either way then haha!! today it "CRUNCHED" into reverse to. thought the gearbox was going to drop out the bottom ha.
dommy147 is offline  
Status: 500 up
AO Member
Join Date: Nov 2011
Location: United Kingdom
County: West Yorkshire
Posts: 638
Easy stuff first. Have you checked there is some oil in the gearbox? When was the oil last changed?
mossca is offline  
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,864
There'll be nothing wrong with the gearbox, it sounds like an actuator problem (although I'm no Selespeed expert). Get someone who knows about them to have a look at it. It might only need calibration.
Rockhopper is offline  
Status: -
AO Member
Join Date: Jul 2014
Location: Scotland
County: Falkirk
Posts: 587

Member car:


If you don't fix it then its a 200-250 car with the box not working. If you are going to keep it/get another alfa then get a set kkl or elm327 cable with alfa adapters for abs/airbag and download either the free version of MultiEciuScan or Alfadiag. They will at least let you start checking for issues and check the clutch rod length. You can even reset your airbag lights !

As said start with the easy stuff. If by any chance the gear selector is flashing on the display when the gears fail to select then the rear sensor on the selespeed actuator may be playing up. Fiddly to change but easier if you have the battery tray out to adjust the clutch rod length.

There are actually 3 of the sensors on the actuator and they are PF2C sensors same as a 106/saxo throttle position sensor. As ever a second hand one would be a bit of a gamble but
Davffc is offline  
Status: -
AO Member
Join Date: Jun 2011
Location: United Kingdom
County: Hertfordshire
Posts: 46
Morning Gents,

I just wanted to say thank you for the download it has worked for me at ten minutes ago.
keith300 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

advice , day , gents , sad

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome