engine management light on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 25-01-15 Thread Starter
Status: -
Join Date: Jan 2015
Location: United Kingdom
County: Midlands
Posts: 2

Member car:

147 jtd

engine management light on

Hi all i purchased a 147 jtd a week ago its a 07 got service history cambelt was changed 20,000 ago i was out in the car last night and engine management light came on and it came up engine system failure it did lose power but got me home anyone got any help on what it might be.
danday is offline  
Sponsored Links
Status: -
AO Member
Conradv2's Avatar
Join Date: Feb 2014
Location: United Kingdom
County: Stirling
Posts: 58

Member car:

Alfa gt jtdm

You are going to need a fault code for this. I use an obd2 Bluetooth device from ebay with 'torque' app on android phone.other options are a set of cables and plugs to connect your laptop.all available cheap on ebay.Theres plenty info on here about which and how to use. Once you have the code it will tell you where the problem is and you can come back here to find out what to do. Good luck.
Conradv2 is online now  
Status: Changed clutch,what's next....
AO Member
Join Date: Jun 2007
Location: South Coast
Posts: 337
Sounds like it went into 'limp' mode after fault came up. Yup, need to get the code.
jdg is offline  
Status: -
Join Date: Apr 2015
County: -
Posts: 3

I've just purchased a 147 jtdm lusso and the engine warning light has come on and motor control system failure. Do I ask for my money back or just get the dealer to fix the problems on the warranty he gave me??
Jake364 is offline  
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,076
Get him to fix it - probably only something minor - perhaps a split hose.
rgwm is offline  
Status: -
Join Date: Apr 2015
County: -
Posts: 3
Thank you.
Jake364 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome