12 inch sub wooffer sounds bad..your experiances? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #26 of 27 Old 03-06-07 Thread Starter
Status: -
AO Member
Join Date: Nov 2006
Posts: 148

Member car:


Re: 12 inch sub wooffer sounds bad..your experiances?

alright u caught me out.. i didnt read it! i had friends over at the time...
but first thing i done was drop the LEVEL.
after reading the site i couldnt help myself but to drive to the rail way line where i could pump up the volume with no one noticing..

i set all the settings back to 'flat'.. including LOud setting (had that on high)..turned sub off..then increase volume too 95 percent where sound quality was beginning to drop. i figured settings of amp was close enough so didnt touch that.

seems i was running alot of bass through the speakers to composate for my sh itty sub...before the changes i only ever ran the HU at 50% volume. thats why i could turn it up now.

then i turn the sub on and ran it at full volume with me face right up against it.. no distortion.. played both rock and rap..

so that was good..i didnt have to touch the amp settings..
then i turned the hpf and lpf to 80 hz..
cracked up the volume again.. the sound was awsome...loud clear and the 'stage' was perfect.. the bass sounded like it was coming from the speakers..

i must have sat in the car for 30 mins enjoying the music after that..
i havent touched the Eq settings as yet.. i'll play around with that tomorrow..

thanks again for all the help and infomation!!!!
makker is offline  
Sponsored Links
Status: bought a 75 3.0
AO Silver Member
155 Lounge Winner 09
shiny_car's Avatar
Join Date: Dec 2006
Location: Australia
County: Victoria
Posts: 7,669
Images: 39

Member car:

GT . 155 . 75

Re: 12 inch sub wooffer sounds bad..your experiances?

nice one. so long as you don't become addicted to car audio like me, you'll be right.

shiny_car is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

badyour , experiances , inch , sounds , wooffer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome