heater - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-01-15 Thread Starter
Status: loving a shiny bella called Monica
AO Silver Member
bigjim's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Northamptonshire
Posts: 1,916

Member car:

159 2.4 Lusso


my heater doesn't really get as hot as it should. normally when it's on 30 deg it's hot enough to make you sick.
also the temp reader only goes up by one section.
could this simple be a thermostat prob and is it an easy job? where's best to get the bit from?
normally i just take it to my indy and get him to fix it but last time i mentioned it he said put something to cover half the rad.
cheers for any help
didn't mention it was a 1.6 147 52 plate.
bigjim is offline  
Sponsored Links
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Sounds like your thermostat has gone, try autolusso they done mine last friday and its now nice and toasty in my cabin.
Durty dog is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome