I'm new please help with my 147 2003 1.9 jtd - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 16-01-15 Thread Starter
Status: -
Join Date: Jan 2015
County: -
Posts: 2
I'm new please help with my 147 2003 1.9 jtd


I have 2 problems, just bought the car couple of days ago,

1. Airbag light on dash was on indicating that the airbags are not working, but after i did kilometer counter reset, the airbag light went off too, should I worry on it anymore or was it just a glitch??

2. Mechanic changed the intercooler (turbine cooler he said) but now when I accelerate in 3rd gear there is a subtle whoosh sound like wind blowing... it is noticeable only in 3rd gear, is there anything to be worried about?? maybe punctured hose or something??

Please help, any help would be appreciated, thank you,
with regards Marko
Grimy is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
If the airbag light is now off, I wouldn't worry about it - all sorts of random electrical issues happen on 147s if the battery gets a bit low

Whooshing sound does sound like an air leak somewhere, but I can't see why it would only be in 3rd gear......worth checking all your hoses, though. I need to do this myself, when it warms up a bit!
rgwm is offline  
(Post Link) post #3 of 5 Old 17-01-15 Thread Starter
Status: -
Join Date: Jan 2015
County: -
Posts: 2

it rained today and the airbag light came back on, and one more thing after a full day on the road wiper function that automatically turns on after you spray the cleaner on didn't work anymore... is maybe the moisture and water causing some sort of electrical issues???

ty, Marko
Grimy is offline  
Status: now a diesel head..
AO Silver Member
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,497
check battery first as rgwm said...

actions before going any further

battery voltage test.

ecu reset.

if this does not cure it then start looking at other things.
joeymannero is offline  
Status: -
AO Member
AfroBeanz's Avatar
Join Date: Oct 2013
Location: United Kingdom
County: Cornwall
Posts: 219
Images: 6
Airbag warning light - Check the wiring block under your seat, sometimes it can work lose and throw up the warning light, simple fix.
AfroBeanz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 2003 , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome