Advice for indicator (likely relay) fault? 04 facelift 156 JTS - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 15-01-15 Thread Starter
Status: -
Benpack's Avatar
Join Date: Oct 2014
Location: United Kingdom
County: Gloucestershire
Posts: 7

Member car:

Alfa 156 Veloce

Advice for indicator (likely relay) fault? 04 facelift 156 JTS

When moving the stalk my indicators flash for a varying amount of time then stop, along with the clicking and dash arrows - yet the stalk remains in position. After removing the cover below the steering wheel I've found the same dead end as other forum users - bosch unit covering relay but found some help in pushing on this when they stop flashing gets them flashing again. This makes me think loose/dirty connection?

>The indicator bulbs all light when locking the car and unlocking so it isn't those
>The hazards are the same as the indicators, sometimes work for a few seconds and cut out (along with clicking) - sometimes will not work at all
>With lower steering column cover off, pushing on the plastic bracket gets them flashing again a few times

TO FIX? So basically, if i call in a favour off a mechanic friend and remove the steering wheel (after having disconnected battery for at least 30 mins), don't touch or move the center piece with the clock spring ribbon in it, remove the bosch unit to then get at the relay...
I'm guessing i could then take the relay in question to a car parts shop to ensure i order an identical one? As still no ones got a definitive relay part to fix this with. I've been driving with indicators that only flash a max of 3 times for almost 3 months now, that with this being my 1st car and new driver = SCARY I need to get this sorted.

I guess what I'm really asking is is this the right solution, or is there an easier way to get at the relay, did anyone have the same problem and it turn out not to be the relay? Do these relays have their spec printed on them making it easier to replace once you have the old one??

Any help would be a god send as i can't really afford to take to a dealer and from other peoples posts here that wouldn't be much use anyway!
Benpack is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

airbag or dashboard , hazard or indicator , indicator , relay , stalk

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome