Lambda sensors - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-05-07 Thread Starter
Status: -
AO Member
mojo_jojo's Avatar
Join Date: Jun 2003
Location: Berkshire, UK
Posts: 912

Member car:

156 JTS Veloce

Lambda sensors

Anyone know how long it should take to change a lambda sensor on a 156 JTS approx?
mojo_jojo is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,288
Images: 12
Re: Lambda sensors

Took my mechanics around 20 mins to do the lowest (and only) one in my TSpark, but I think the JTS may have three lambdas.

Hint: Tie a piece of string to the plug before pulling it down the back of the engine ... you can use the string to pull the new one back up. It would have taken them ten minutes this way ...
gazza82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

lambda , sensors

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome