147 rear hub bush replacement! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-05-07 Thread Starter
Status: -
Join Date: Jun 2006
Posts: 6

Member car:

146 TI

147 rear hub bush replacement!

hi all,

ok need some advice on removing the rear hub bushes, they have just started knocking had a quick look and check tighten still knocking. Bought the bushes but the old one doesnt wanna move, rubber is loose from metal houseing. transverse long bolt is solid so not going to touch that! how do i get some access!

Ive tried swinging and swinging and the bloody thing wont budge, even with heat!

any ideas

daisycutter is offline  
Sponsored Links
Status: -
AO Member
Rab's Avatar
Join Date: Aug 2006
Location: Oxfordshire
Posts: 31
Re: 147 rear hub bush replacement!

I don't know too much about this, but when I had the suspension on my 147 looked at by Palmer & Phillips in Oxford, it was due for new rear bushes. They said they charge an hours labour per side, but it sometimes takes longer because of a long bolt (not sure if they meant the transverse long bolt).

You could try being cheeky and giving a specialist garage a ring and seeing if they'll tell you how they do it.

If not, the threads been bumped anyway, so maybe someone can help!
Rab is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , bush , hub , rear , replacement

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome