Crank Sensor Quick advise please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-01-15 Thread Starter
Status: Busy
AO Member
biddyrascal's Avatar
Join Date: Nov 2014
Location: United Kingdom
County: Cheshire
Posts: 183
Images: 16
Crank Sensor Quick advise please

As previous posts i've got a 2005 156 JTS non starter with P0335 crank sensor fault code.
Got replacement sensor based on giving Registration number to motor factor and its the wrong one.
They Supplied sensor with long lead connected to brown plug, my sensor only plugs into loom, no lead.
First question, have i removed the correct sensor from under the starter motor?

Second question, i am doubting the sensor is at fault, apparently they fail by losing magnetism? the one ive just taken out can lift my 1/2" drive snap-on ratchet !

What do you think?

Always looking for the next project, why have 1 boring new car when you can have 3 or 4 decent project cars ?
biddyrascal is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2014
Location: Scotland
County: Falkirk
Posts: 587

Member car:


Yes that'll be the crank sensor you have removed its the only one really in that area however I think they have supplied a sensor for the earlier 156/147s.

Check this page for the one you need
Alfa Romeo 156 Sensor-Crank
Davffc is offline  
Status: -
AO Member
saintetienne's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: East Sussex
Posts: 816
Images: 30
When most sensors fail they often become temperature sensitive and fail when car is hot , sometimes it will cool down and start so I don't think you can really be sure if yours is ok by what you say.

Last edited by saintetienne; 11-01-15 at 13:56.
saintetienne is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

advise , crank , quick , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome