Faulty injection relay - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-01-15 Thread Starter
Status: -
AO Member
Join Date: Apr 2012
Location: New Zealand
County: Auckland
Posts: 128
Faulty injection relay

My 156 v6 liked to intermittantly stutter and die on me. It felt like a fuel problem. No error codes were stored so I checked the fuel pump and injection relays.

I opened the injection relay and spotted the problem. The coil windings are secured with a spot of booger which just happened to eat through the enamel and corrode the copper wire. It wasn't too hard to wind back a couple of turns to a get beyond the corroded section and resolder it to the diode.

I also cleaned the contacts of both relays with contact cleaner and 1000 grit wet n'dry.

Replacing the relay will also work of course, but that's no fun!
Heavend is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

faulty , injection , relay

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome