Alfa 147 1.6 TS strange noise upon speeding - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-01-15 Thread Starter
Status: -
Join Date: Jan 2015
Location: Hungary
County: Baranya
Posts: 1

Member car:

Alfa Romeo 147

Alfa 147 1.6 TS strange noise upon speeding

Hey guys,

I bought this lovely car 2 months ago. I changed the compelete control, gave her selenia motor oil, and some small modifcations were made.

This morning i noticed a strange noise when I accelerate and I'm really worried, for one, when I start the car after a cold night it is clear and loud that the Timing Belt is loose and gives a abrasive sound.

My question is why do I have strange noises coming from the car when I accelerate, could it be associated with the loose timing belt?
LeviD77 is offline  
Sponsored Links
Status: Rupert Gaylord Egger of Eggington Hall
AO Gold Member
rugbymike7's Avatar
Join Date: Jan 2014
Location: United Kingdom
County: Hampshire
Posts: 6,919
Are you sure it's the timing belt and not the auxiliary belt?

Either way I wouldn't drive it until it's sorted as if the timing belt is loose you'll damage valves. And if it's the auxiliary belt and it comes off it could take the timing belt with it and knacker your engine.
rugbymike7 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , noise , speeding , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome