2.0 JTS - bits and bobs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-05-07 Thread Starter
Status: is a state, condition or situation
AO Silver Member
Pea Sea's Avatar
Join Date: May 2007
Location: United Kingdom
County: North Yorkshire
Posts: 2,638
Images: 16
2.0 JTS - bits and bobs

Any advice welcome on some minor (I hope) things:

1 - I assume it is not uncommon for the plastic flexi covers to the cables feeding the plugs become brittle and simply fall to bits. Has anyone any ideas on what to replace them with - or is it back to the Alfa dealers aprts dept?
2 - Like wise the long plastic tube that the flexi pipes come off, that runs along the front of the engine (in front of the plugs). It has snapped because its so brittle - is this fairly common.
3 - The engine has used approx 2 lts of oil this week in some 1500 miles. There's no evidence of a leak under the engine - BUT - there is oil in the recesses where the plugs are and the seal around the filler cap is snagged. Is there enough back pressure for oil to leak out the top of the engine?? (No signs of it burning any oil)

I've only had the car a week and its a 2002 with 88000.



Avoid the Calamari

It sucks...

Pea Sea is offline  
Sponsored Links
Status: -
AO Member
mojo_jojo's Avatar
Join Date: Jun 2003
Location: Berkshire, UK
Posts: 912

Member car:

156 JTS Veloce

Re: 2.0 JTS - bits and bobs

3 - One litre per 1000 miles is average normal use but it depends on your driving techniques. Seems to be drinking 1 lt per 750 miles approx for you. Can't see why it sould be leaking from the top unless the engine cover wasn't on properly.

Not sure about questions 1 & 2.
mojo_jojo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bits , bobs , jts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome