New GT Owner....A few queries - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
New GT Owner....A few queries

Good day all...

Recently picked up a 2006 GT JTDm, I have wanted one for years but always had company that's not the case I decided to jump in and must say I am delighted with it!

The previous owner hasn't looked after it well at all, so I have some work on my hands unfortunately...but it drives excellently!

Anyway, I have a few queries that I have picked up over the past few weeks:

1 - The car is warning me that I have a light failure, I have checked and checked again, all bulbs are in working order....could this be something I'm missing?

2 - How easy is centre console swap out? The previous owner has cracked mine - but instead of trying to fix it properly has just drilled two holes and cable tied the break together. Also the cigarette lighter isn't the best, chargers don't sit properly etc due to damage.

3 - Whilst attempting to clean the interior, I pulled up the little rubber mat next to the handbrake and revealed a small electrical connector (two pin plastic about an inch long) - is this standard? What's it for?

That's all I can think of right now...all help appreciated!
Sponsored Links
Status: turbo charger assembler
AO Silver Member
Join Date: Nov 2010
Location: United Kingdom
County: West Yorkshire
Posts: 1,928
waht lights is it telling you are out , mine says number plate or sidelight etc....there are two numberplate lights are they both working......are both sidelights working.... all u can do if everything is working is to try re seat the bulbs

cant see ceter console been hard to change

its normal for that connector cant remember what it is for but it should be there
hdseven is offline  
Status: turbo charger assembler
AO Silver Member
Join Date: Nov 2010
Location: United Kingdom
County: West Yorkshire
Posts: 1,928
quick search says its something to do with a bose system that plug.
hdseven is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
As above, numberplate lights are often missed.

Also, check that they are proper bulbs and not LEDs.
LEDs without a load resistor will bring on the warning light even though they are working.

Remember that the only lights monitored are:
Front sidelights (The H6W ones)
Rear sidelights
Brake lights (not the centre one)
Rear fog

If all are ok then I think it can point to a body-computer issue on the 147/GT.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

ownera , queries

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome