Engine rattle on start up when cold - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-12-14 Thread Starter
Status: -
AO Member
7OHNGT's Avatar
Join Date: Jul 2013
Location: United Kingdom
County: West Midlands
Posts: 195

Member car:


Engine rattle on start up when cold

only seems to happen when the engine is cold.

engine will start then after 2seconds this rattle (like its misfiring maybe) happens. a dab of the revs and it stops. it will only do it for a couple of seconds.

glowplug relay error appears on dash - although dont know if this is linked, as the error msg appears nine times out of ten even when engine is warm.

glowplugs were changed about a year ago.
7OHNGT is offline  
Sponsored Links
Status: Busso
AO Silver Member
Join Date: Apr 2012
Location: United Kingdom
County: Berkshire
Posts: 2,548
Would guess that one or more glow plugs have failed, or the timer is shutting them off early. If it gets worse at lower temperatures, then it is almost certainly glow plug related. Basically you've got some cylinders firing and others missing for a few seconds. Not the end of the world, but it will get harder to start every morning as winter gets properly cold...
rxe is offline  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Cam followers waiting for that life blood to circulate, with lazy valve operation maybe?
zulu ferret is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cold , engine , rattle , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome