147 Rear Wiper Stuck and Fixed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-05-07 Thread Starter
Status: -
AO Member
Join Date: Nov 2005
Location: Gloucester UK
Posts: 233
Images: 2

Member car:

147 Selespeed

147 Rear Wiper Stuck and Fixed

Oh no, my rear wiper stopped working. But I fixed it!! Having read various threads on the issue I was nearly convinced that a new motor was needed. But no. All that happened was that the area under the black cone which covers the motor spidle was so full of muck that the poor wiper arm could not move. A quick brush out and a splash of grease spray and the wiper action is as good as new. Just thought you guys might want to clean out this wiper area on your 147s before you experience what I did.

Dai Alfa is offline  
Sponsored Links
Status: -
AO Member
alfa1999's Avatar
Join Date: Dec 2005
Location: Ealing, London
Posts: 308
Images: 2
Re: 147 Rear Wiper Stuck and Fixed

wow thanks, i got this issue at the mo (wiper not working and flopping down + no spray) & have been looking into a new motor (£85), but after reading your comments i will try what you did! i hope its thats simple
Thanks very much
alfa1999 is offline  
Status: 147 QVD-R
AO Silver Member
kgb's Avatar
Join Date: Apr 2003
Location: Bulgaria
County: -
Posts: 2,250
Images: 26
Re: 147 Rear Wiper Stuck and Fixed

I have the same problem now....

My wiper stopped exactly in the middle, looking like tuned VW GTi....the bad thing is now one believes me that it is broken....everyone thinks I did it on purpose.

Thanks for the advice....I will have a look tomorrow...
kgb is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , fixed , rear , stuck , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome