Gt immobiliser /fuse issue update ! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-12-14 Thread Starter
Status: -
AO Member
Join Date: Oct 2013
Location: United Kingdom
County: Hampshire
Posts: 30
Gt immobiliser /fuse issue update !

Well was popped into local main dealer where they carried out test on keys . As previous I have had all issues with new 6 mth old key from them, intermittent then breakdown twice with control body fuse blowing 2secs after start up.

Old key 7 turns no issues

New key 3rd turn fuse blows in work shop.

New key ordered.. Fingers crossed. They have never seen this but defo said to do with key somehow.

Also changed two side light bulbs, what an absolute nightmare especially with (crap) xenons.
Alfas were defo not engineered more designed!!!! There electrics truely still way behind in reliability.

Will return with outcome of 2nd new key. Cheers
Gobert is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

immobiliser , issue , or fuse , update

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome