Singing JTDm 16v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-12-14 Thread Starter
Status: Happy Alfa Driver
AO Member
Join Date: Jan 2012
Location: United Kingdom
County: Gloucestershire
Posts: 25
Images: 2
Singing JTDm 16v

Hi All,

Just after a bit of advice. I've had my 147 JTDm 16v for nearly a year now and I love it. When I first got the car I changed the cam belt, water pump and aux drive belt & tensioners. When I had done this she started fine, but made a sort of resonating whine, but I thought nothing of it and the car has been running fine ever since. The other day a colleague said that the whine was really quite loud and my car was audibly recognisable from a distance away!

My question to you good people is could this noise be caused by something I have done wrong, if so what (over tensioned a belt or whatever)? Further to this it begs the question could it possibly be doing the engine some damage??

I'd be interested in your opinions. TIA.
Currantbun34 is offline  
Sponsored Links
Status: -
AO Silver Member
JON156VELOCE's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cardiff
Posts: 2,026
Maybe you need to whip the covers off and check the belt tension.

The procedure for doing the belt does say that you should put the tensioner to the tightest position, turn the engine over twice and then reset the tensioner pointer to the hole in the tensioner back plate, you did do the second part I hope.?
JON156VELOCE is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

16v , jtdm , singing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome