156 Sportwagon suspension - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 16-11-14 Thread Starter
Status: -
Join Date: Aug 2014
Location: United Kingdom
County: Highlands
Posts: 1
Hmmm 156 Sportwagon suspension

Hi all,
Long term lerker, first time poster.
Bought my 54 plate 1.9 JTDm a few months ago and have slowly been going through a to-do list...
So far replaced :
Front discs (L + R),
Front pads,
Lower wishbones (L + R)
Upper wishbones (L + R)
A R B Droplinks (L + R)

And yet still getting a (passenger side) knock. Sounds like a bad drop link would make, kind of rattly over rough roads. Every nut is tight, all replaced parts are good quality but now starting to throw money at a problem that scuppered me.
Other than the strut mount - do you guys have any other areas to investigate?
Would an engine mount make a loose, rattle like tap over bumps and rough roads?

Relative novice, know the basics but now this one has stumped me so apologies for what may be a daft question

j60dnl is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,239
Sounds like an anti roll bar bush. Where it mounts to the subframe. Very common.
sprint_veloce is offline  
Status: -
AO Member
Join Date: Sep 2014
Location: New Zealand
County: -
Posts: 37

Member car:

'99 156 2.5 V6

I have a similar sound coming from my 156 sedan (saloon). I had all the front wishbones and discs + pads replaced as well, 2 months ago.

Mine doesn't do it on all bumps, there seems to be a specific angle or force you have to hit for it to make the sound.

My mechanic didn't seem to think it was an issue worth fixing, but it is irritating.
dylanj is offline  
Status: -
AO Member
Join Date: Sep 2014
Location: New Zealand
County: -
Posts: 37

Member car:

'99 156 2.5 V6


Last edited by dylanj; 17-11-14 at 02:51. Reason: oops, browser lagged and double posted by accident
dylanj is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , sportwagon , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome