Selespeed 2nd to 5th then N - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-04-07 Thread Starter
Status: -
Join Date: Apr 2007
Posts: 2
Selespeed 2nd to 5th then N

Hi, Ive just bought a 2002 156, my first Alfa, and discovered why it was sold at auction! The problem is specific and consistent so hopefully someone can help. The gear changes work perfectly when cold in city or button change but once engine temp reaches 90 the gears jump from 2nd to 5th on change up and changing down go straight to neutral. Thereafter 3rd and 4th are totally ignored unless travelling fast and cooling the engine. Local Alfa agents don't want to know without serious replacement costs and local 'specialists' are at a loss as diagnostics read no problems. Have found a replacement 6 month warranty box and actuator for 375, should I buy?
nilechamp is offline  
Sponsored Links
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Selespeed 2nd to 5th then N

Difficult one to advise on. But if you have been through all the basics on the tech forum info. on Seles' posted by numerous folks, David C, Ben, Wrenched and so on, starting with the 'excellent' battery factor, then, when all options have been exhausted, you are left with that decision of the replacement box? Try a few of the listings in the tech stuff that has been suggested first though. Good Luck:
zulu ferret is offline  
Status: -
AO Silver Member
Wrenched's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: Warwickshire
Posts: 1,807

Member car:

GTV 24v

Re: Selespeed 2nd to 5th then N

I can't claim to have any selespeed experience to be honest, but have experience of some of the hydraulic parts courtesy of Citroen ownership. MAybe the gear position sensors on the gearbox but, I'd want to be quite sure all electrical connectors are good before anything else.
Wrenched is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

2nd , 5th , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome