Help! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-04-07 Thread Starter
Status: -
Join Date: Apr 2007
Posts: 1

Hi Guys,

I've joined the forum at the outset to hopefully establish a number of recall issues and problems that have been encountered with heated rear windscreen operation on a Alfa 147 1.6 ts Lusso. The car is owned by my girlfriend who was a dedicated Alfa worshipper. However, over the six years of ownership, snapped cambelt, power steering problems, along with pretty bad work carried out by three diffrent Alfa dealerships she is pretty perplexed at the horrendeous bills she`s now confronted with. At the last service we found out that the sump plug had been stripped and botched. Apparently. in 2006 ALfa advised the cambelt on the 147 1.6 ts should now be changed at 36k intervals? was anyone advised through Alfa? my gf wasn`t, from any one of the three Alfa garages or indeed Alfa itself. To add insult to injury the car went in for a service 500 miles ago at Alfa dealership it came out after being serviced. Having read various post over the last couple of weeks re the cambelt I nipped the car into an independent garage where we were informed that the cambelt had started to delaminate the teeth coming off and the drop links on the front suspension were shot and the antiroll bar bushes were in the same condition not what you would expect from Alfa or is it? Suffice to say the cambelt was changed along with front suspension parts. To add insult to injury the service info on the mapping/computer system has not been reprogrammed ,its now showing its past its next service date. Does anyone know a good Alfa specialist in or around the North West?

Apologies for harping Dave 147
Dave147 is offline  
Sponsored Links
Status: -
AO Silver Member
phil155's Avatar
Join Date: Jul 2005
Location: half way up the A12
Posts: 5,093
Images: 24
Re: Help!

welcome to alfaowner dave i have moved your questions into the 147 tech section, that should get you sorted
phil155 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome