crunchy noise while breaking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-11-14 Thread Starter
Status: -
Join Date: Nov 2014
Location: United Kingdom
County: Wiltshire
Posts: 2

Member car:


Looky Looky crunchy noise while breaking

When I break, I have loss of break pressure and crunching noise.
My break pads and disk are okay.
A garage said it would be the ABS pump pressure which causes the issue.
I have no ABS lights flashing on the dash, only the annoying crunching......
Any idea?
Is it really the ABS pressure pump? And can that be easily fixed?
The orange coloured well known garage would / could not diagnose it properly, just guessed (took them 2 hours) and advised me to go to a dealer garage......which would obviously cost me an arm and a leg!

Last edited by Ralf the Romeo; 09-11-14 at 19:17. Reason: typo
Ralf the Romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

breaking , crunchy , noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome