156 Front suspension squeeky - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 04-11-14 Thread Starter
Status: -
AO Member
Join Date: Jul 2014
County: -
Posts: 14

Member car:


156 Front suspension squeeky

Hey .. sorry for multiple threads. I just adore my latest Alfa so much, and the Alfa paranoia is setting in already.

I just bought the car. 2003 plate 156 1.6 TS. The garage is bought it from had to do a bunch of work to get it through the MOT, including new bushes and ARB's, and some welding underneath. All good

This is my fourth 156, im not very merchanically minded but i have driven many a mile in a 156 so i know from a driver perpective.

My last Alfa, well, it was knackered really in the end. Needed new wishbones etc, and would make an awful squeeky creaky noise whenever you went over a bump, or any kind of uneven surface.

My new 156 ... drives beautifully. really lovely solid drive. First 50 miles i did in it, flawless, and i was loving the fact that it did not make a sound at all when hitting any bumps in the road etc ... then last night it has started making a little squeeky noise if i hit a bump in the road.

I actually curbed it! Went to park and go slightly up a kerb, and did not take into account the 17 inch alloys, and the alloy scraped the curb, wasnt too mugh impact. since then, little squeeky noise

still drives real nice, but that sqeeky noise is really worrying me. It isnt really loud, just a real slight " eeky eeky " effect un uneven surfaces.

any advise ?

Blue_Scholar is offline  
Sponsored Links
Status: still excited(shoudn't be)
AO Gold Member
ARnovice's Avatar
Join Date: Dec 2013
Location: The land of burning...
County: Berkshire
Posts: 7,784
Images: 3
normally that squeaky sounds on uneven surface comes from upper wishbone...
ARnovice is offline  
(Post Link) post #3 of 5 Old 05-11-14 Thread Starter
Status: -
AO Member
Join Date: Jul 2014
County: -
Posts: 14

Member car:


Today after driving for about 4 miles, the squeek just completely went. it is running real quiet now.

I have it booked in to Northern Alfa in Doncaster in a few weeks for a service and cambelt change, so reckon ill ask the guy to have a peep at the suspension too.
Blue_Scholar is offline  
Status: It's fairwell to the 156.
AO Member
Teuchter's Avatar
Join Date: Mar 2012
Location: United Kingdom
County: Highlands
Posts: 258
Images: 10

Member car:

156 2.5 V6 SW

I'm in the same boat as you Scholar, and the creaking/squeaking comes and goes too. Had my upper wishbones done a couple of weeks ago and it still hasn't made a difference so my suspicions lie with the ARB as the noises started after I had a stiffer one fitted. Hopefully when Autolusso North open I'll have it checked with them. All the best, Gavin.
Teuchter is offline  
Status: Why bother with 3 cylinders when 6 will do?
AO Silver Member
Mymatemarmite's Avatar
Join Date: Sep 2012
Location: United Kingdom
County: Devon
Posts: 1,677
It's worth noting that worn antiroll bar drop links can make a very similar noise to the well known 'upper arm' squeak. During the wear phase the drop links will start to squeak/creak way before they begin to rattle. Taking them off (4 nuts and 2 minutes work once the car is in the air) and securing the antiroll bar (with cable ties) is a good way to determine the fault. It could of course be the antiroll bar bushes too but in my experience when these are worn the play felt through the pedals actually far outweighed any creaking sound. If the droplinks look old it's worth starting there as they are the cheapest part of the front suspension to buy.
Mymatemarmite is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , front , squeeky , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome