147 airbag fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 01-11-14 Thread Starter
Status: -
Join Date: Nov 2014
Location: United Kingdom
County: Antrim
Posts: 1

Member car:


147 airbag fault

Hi having trouble with an airbag fault on my 147
Fault code of07, passenger side airbag squib , value too high

Any info would be great thanks
BonzoR is offline  
Sponsored Links
Status: Vantastic
AO Member
vantastic mark's Avatar
Join Date: Oct 2013
Location: United Kingdom
County: Tyne and Wear
Posts: 50
Images: 4

Member car:

Alfa & scoob

Wrong lounge mate
vantastic mark is offline  
Status: -
AO Member
Join Date: Jul 2014
Location: Scotland
County: Falkirk
Posts: 587

Member car:


Wrong lounge indeed but its your passenger airbag. Probably loose connection under seat. Very common issue
Davffc is offline  
Status: Lots to do
Global Mod Team
paul.o's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: Lancashire
Posts: 3,794
Images: 58
Moved it
paul.o is offline  
Status: -
AO Member
Join Date: Jul 2011
Location: Macedonia, The Former Yug
County: -
Posts: 562
passenger side airbag squib

Look in the boot, in the small pockets, next to the tail light, for yellow wire (passenger side I guess, if Tony does n`t mix with other nonUK ) . Disconnect it, spray with contact cleaner, leave it 30 min, connect and secure with something.

If your car is >2003 error should go after 3 times on MAR. If not, only FES with airbag adapter will clean the error.

Toso is offline  
Status: -
AO Silver Member
TOX1C's Avatar
Join Date: Aug 2004
Location: Amesbury
County: Wiltshire
Posts: 4,325
Images: 9
I've had the same fault - passenger curtain, it started intermittently and is now permanent. As has been said the connector to the squib is under the trim in the left side of the boot, but that has already been cleaned previously and cable tied. I did have a fault that reported a driver side that turned out to be passenger side, so they may be crossed over, apparently that has been known.
TOX1C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , airbag , fault

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome