Help! NAV+ asking for Master Code - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-04-07 Thread Starter
Status: -
AO Member
Join Date: Sep 2004
Location: Nr Wigan
Posts: 161
Help! NAV+ asking for Master Code

I had the body computer replaced early March, and since that was done the Connect NAV+ unit asks for a master code. I tried the code i had but it was rejected. I paid my local Alfa Dealer to get the codes and fix it. They tried that and that didn't work.

They have had the car since Monday this week, and they still haven't fixed it. I opened a case with Alfa GB, and they too are lost.

End result - car has been in the garage since Monday, they don't know why it won't work.

So with the dealer talking to the car makers, they don't know why their equipment isn't working. I have given them until Tuesday evening now to fix it.

What are my options??

Anybody out there have a bigger or better brain than Alfa GB???

Anyone been through this experience before??

My only option it seems is to take the car back and rip out the NAV+ and replace with a stereo/gps/Nokia 616 unit which might not work with the factory supplied bits.

Lost and depressed....

royster-doyster is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Help! NAV+ asking for Master Code


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

code , master , nav

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome