147 jtd loud noise at idle (a/c pump?) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 06-10-14 Thread Starter
Status: fitting bose to a 147
AO Member
Join Date: Jan 2009
Location: United Kingdom
County: Kent
Posts: 69
Images: 3
147 jtd loud noise at idle (a/c pump?)

hi ive got a 2004 1.9 16v jtd that has developed a loud rattle/groan at idle, its something to do with the aux belt as when thats removed the noise goes away,
it only does it at low revs (under 1200rpm) and the sound doesnt seem to change note if the revs increase, theres no aparant play in any of the idlers or pulleys but it does seem louder towards the front of the engine around the a/c pump, i suspect this may be the issue but having said that it makes no difference to the sound if the a/c is on or off,

car drives spot on and everything works fine

any sugestions before i start swappping random parts
slidersi is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , a or c , idle , jtd , loud , noise , pump

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome