Grrrrrrr. Selespeed problem has fully returned - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 30-03-07 Thread Starter
Status: -
AO Member
Ben B's Avatar
Join Date: Nov 2006
Location: Bury St Edmunds, Suffolk
Posts: 341
Images: 12
Grrrrrrr. Selespeed problem has fully returned

I can't beleive it, thats about 3 times today I've been put into Neutral while driving. I can't understand how a problem can be temporarily fixed, for a couple of weeks, then come back again to happen loads in one day?

I also had the random gear number display again, and plenty of flashing numbers.

It's odd, as these are seperate problems, which were invidually fixed, (They found powersteering fluid in the sele fluid, gave it a new earth cable, plus changed two potentiometers on the actuator (they tell the system which gear you are in)) to so I can't see why both probelms would come back, unless they were caused by the same thing?

When it was just a flashing gear number and occasional neutral I was thinking it had to be the pump needed overhauling this time, but now the gear display is going weird I just dont know.

. : Alfa 147 2.0 Selespeed : Tan Leather : Bose Sounds : 17" Supersports : 40mm Lower : HK Drive & Play Ipod Kit : .
SOLD Maybe staying with Alfa though, see what I end up with next!
Ben B is offline  
Sponsored Links
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Grrrrrrr. Selespeed problem has fully returned

No ideas really mate, maybe David C may have, don't suppose it could be that 'nasty' the Sele ECU, thats playing up?
zulu ferret is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fully , grrrrrrr , problem , returned , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome