Can anyone tell me what THESE are for? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 02-10-14 Thread Starter
Status: "Ruby" has been Torpedoed!
AO Member
bazzbazz's Avatar
Join Date: Apr 2013
Location: Brisbane Australia
County: Queensland
Posts: 207

Member car:

Alfa 156

Can anyone tell me what THESE are for?

Am helping friend get a 2003 156 JTS Sedan ready for sale, the Selespeed pump needed new brushes, so as I was taking the left front wheel arch lining out THESE fell down.

Cables A.jpg

Cables B.jpg

Cables C.jpg

Cables D.jpg

Never seen anything like these before, they were just up there on top of the wheel lining, as you can see one of the plugs is pretty badly damaged.

Now the car is also having problems with Eng Management, VDC, EBD, ABS failures & is in "Limp Home Mode" Could these have anything to do with these errors?

bazzbazz is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,288
Images: 12
Got an alarm? Is it working?
gazza82 is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,994
Alarm would be my first thought too.
It is the correct location and some markets didn't get an alarm as std, but the wiring would probably still be there.

Last edited by David C; 02-10-14 at 10:17.
David C is offline  
Status: -
AO Member
Join Date: Sep 2013
Location: United Kingdom
County: Devon
Posts: 160

Member car:

156 166 & F3.2

Definitely the alarm module connectors (looks as if one of the connectors has been in a fight and lost!).
anonima is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome