Alfa 147 Engine turns off at around 90 degrees (Please help :( ) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-09-14 Thread Starter
Status: -
Join Date: Sep 2014
Location: United Kingdom
County: West Yorkshire
Posts: 6

Member car:

Alfa Romeo 147

Alfa 147 Engine turns off at around 90 degrees (Please help :( )


I've just bought an alfa 147 2005. Was enjoying the drive home, but then, at a corner, while going from stopped, just turned off. After a few attempts to turn it back on the engine was just turning over. After it cooled down slightly it turned on again. Only then I realised that the car turns off at low revs whenever it reaches 90 degrees engine temp...

Anybody have any suggestions what it could be?
SocialistDonkey is offline  
Sponsored Links
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,864
Failing crank sensor? Get the fault codes read to confirm.
Rockhopper is online now  
Status: -
AO Member
Join Date: Jul 2014
Location: Scotland
County: Falkirk
Posts: 587

Member car:


Originally Posted by rockhopper View Post
failing crank sensor? Get the fault codes read to confirm.
Davffc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , degrees , engine , turns

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome