147 intermittent brake light (drivers side) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-09-14 Thread Starter
Status: -
AO Member
Join Date: Mar 2007
Posts: 35

Member car:


Help 147 intermittent brake light (drivers side)

Hi Folks

Need some guidance on this one. Car is a 2002 147 2.0TS

The driver's side brake light appears to be intermittent with a flicker on the first pedal press. It seems to get better with subsequent presses but the light is not solid like it should be. I changed the bulb and still have the same issue. Passenger side is fine.

I noticed that it gets better / non-existent when the lights are turned on. It's almost like the circuit needs to warm up or something?!

It got dark before I could try swapping over the bulb holders, will give that a try tomorrow.

Beyond that, does anyone have any ideas?

MOT is scheduled for Monday.....hoping that this does not cause a failure.

Thanks in advance!
Axl is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Corrosion on the bulb holder or plug I'd have though.
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , brake , drivers , intermittent , light , side

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome