failed the mot - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
Join Date: Feb 2007
Location: N.Somerset, UK
Posts: 5
Re: failed the mot

Had the same snag myself with my 1.8 TS failing the MOT on emissions with dismal results. The garage threw some "industrial" fuel cleaner through the system at a cost of 20 which solved the problem and was a lot cheaper than the Lamda Sensor. How did you get on ?
GGBarnes is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2006
Posts: 28

Member car:

Alfa `156 2.0 TS

Re: failed the mot

I took my alfa last week for an MOT. It was failing the emissions at one stage (readings of almost .100 ,and i was told that im allowed up to .20 .Anyways after the MOT tester kept it on high revs for a minute or so the readings fell to .1 .I asked why the large change in readings.He said the cat just needed to be warmed up. The car passed the emission easily even though it was sweats at one point.
m8gic is offline  
Status: - Update
Posts: n/a
Re: failed the mot

Its always good practice to take the car for a reasonably energetic 20 mile drive before an emissions test to get the cat good and hot ands working. I've sold it now and sent the data sheets with it, but my 24valve V6 was always as clean as a whistle after a new lambda sensor in 2003.

I don't think pouring ANYTHING down the engine is a good plan at all. It could easily kill the catalyst. Cats last an amazingly long time as long as you don't poison them with lead or put raw fuel in them, but the O2 (lambda)sensor is a legitimate service item every four or five years I suspect (though our Skoda one has done nine years so far). Most decent garages can test the lambda signal and see if its OK using a test/multi-meter.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failed , mot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome