Alfa GT JTDM - Can't select any gears!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-09-14 Thread Starter
Status: -
Join Date: Jun 2013
Location: United Kingdom
County: South Yorkshire
Posts: 4
Help Alfa GT JTDM - Gearbox linkage. Can't select any gears!!!

After starting up the car, I could not select any gears at all. Gearstick could be moved like stirring some porridge
I'm not the most technical, but have managed to find the problem The threaded bar that connects the cable to the ball joint has pulled out of the nut on the cable. I can only get it screwed in about 2mm and it is not holding, so I think that part of the bar has sheared inside the nut, or it has pulled the threads. See photo, the black nut should be connected to the exposed bit of thread that is sticking out of ball joint.
Has anyone else had this problem? and how did you fix it? I assume a new cable/nut may be required, does anyone know the part no.s?
Thanks in anticipation
Attached Images
File Type: jpg 063.jpg (52.4 KB, 8 views)

Last edited by Rich2712; 09-09-14 at 11:59. Reason: adding photo
Rich2712 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , gears , jtdm , select

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome