Power Steering Pipes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 29-08-14 Thread Starter
Status: And So It Begins!!
Spudicus's Avatar
Join Date: Aug 2014
Location: United Kingdom
County: Northamptonshire
Posts: 7

Member car:

Mini Cooper

Hmmm Power Steering Pipes

Hi All,
Need to replace the power steering pipes on my 147 1.6 TS. Are all the petrol engine variants the same when it comes to the power steering systems?
Spudicus is offline  
Sponsored Links
Status: got a new busso s.w.
AO Silver Member
gibot123's Avatar
Join Date: Aug 2013
Location: United Kingdom
County: East Sussex
Posts: 1,670
Yes pretty certain they are they are probably the same on 147/GT/156.
gibot123 is offline  
Status: Powered by coal and steam
Club Member
Membro Premio
EVEL's Avatar
Club Member Number: 1382
Join Date: Jan 2007
Location: England
County: West Midlands
Posts: 9,808
Images: 7

Member car:

alph a ramayo

Here you go chap


Got mine for my GT from this chap , came well wrapped OE part.
EVEL is online now  
Status: Alfa nut
AO Silver Member
Join Date: Dec 2011
Location: United Kingdom
County: East Sussex
Posts: 1,271
The pipes usually fracture at the clamp just above the crank pulley on the inner wing.They are low pressure so cut them and slide on rubber tubing and tighten with jubilee clamps.Costs about 5 ive probably done 20 in the last 5 years.
jim hazell is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

pipes , power , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome