Bulb warning light flashes when touch the brake pedal - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 26-08-14 Thread Starter
Status: -
AO Member
William Carr's Avatar
Join Date: Aug 2013
Location: Norway
County: Østfold
Posts: 164
Images: 4

Member car:

156 - 98 MODEL

Bulb warning light flashes when touch the brake pedal

My 98 156 failed MOT today. Nothing major. The left side rear blinker and stop light was not working.

I cleaned up the contacts and all is well. However the bulb warning light flashes once whenever I hit the brakes. Anyone heard of this before?

They also said that the car was "lacking parking lights" but they simply had not understood how to turn them on with the black push button by the igintion switch. Back park lights work. Front needs new bulbs..

William Carr is offline  
Sponsored Links
Status: Race cars in progress
Club Member
Membro Premio
Gertie's Avatar
Club Member Number: 2201
Join Date: Oct 2007
Location: South Africa
County: Gauteng
Posts: 5,259
Images: 6
I think they were referring to the small globes in the front. There is still some impedance mismatch with them out - fix the front park lights and the flash of the warning light should disappear.
Gertie is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,288
Images: 12
Check you have H6W bulbs in the parking lights. These are HALOGEN bulbs with offset pins. It is possible the previous owner tried LEDs or forced normal bulbs in there ... and they screws up the impedance. I binned my LEDs as they failed quickly and started to flicker .. causing the warning light to flicker too.

Don't fit cheap bulbs .. they don't last ... and East Asia/East Europe copies tend to feel loose in the holders.
gazza82 is offline  
Status: If its got tits or wheels its going to cost you!!!
AO Member
kevmjtd's Avatar
Join Date: May 2011
Location: United Kingdom
County: Bristol
Posts: 359

Member car:

alfa 156 2.4 jtd

My 156 was doing this when I put my indicators on!
It's was a bad earth in back indicator changed it now sorted .

Clean up your brake light contacts

Last edited by kevmjtd; 27-08-14 at 11:48.
kevmjtd is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

brake , bulb , flashes , light , pedal , touch , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome