Alfa 156 gone funny after exhaust change - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-03-07 Thread Starter
Status: -
AO Member
Join Date: Oct 2006
Posts: 28

Member car:

Alfa `156 2.0 TS

Alfa 156 gone funny after exhaust change

Hi all,
Yesterday i changed the front section of my exhaust(Manifold to just before the cat).The previous one cracked in half where the mesh is.Anyways when i woke up yesterday to take it to the garage.The car was acting funny,revving so low under 0.5 rpm the car felt like its was going to cut out(which actually did a few times)and also when i tried to drive it the car didn't want to move,no power.I thought this was due to the pressure of the exhaust etc.So i gave it a lot of revs in neutral just to free it up and the car seemed fine after tha(drove ok,no jerkiness).When i taken it to the garage it cost me 70 parts + labour and started the car and drove it home fine around 3pm.When i then got back into the car at 9.30pm same problem,car was reving so low the headlight was goming dimmer and brighter and it revved to the point of cut car was undrivable as it kept stalling.Just want any advice on what this could be. By the way the lanbda was put back tightly.
m8gic is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , change , exhaust , funny

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome