Selespeed problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 20-08-14 Thread Starter
Status: -
Join Date: Oct 2013
Location: Turkey
County: Turkey
Posts: 7

Member car:

Alfa GT

Selespeed problem


Although I bought a new actuator few months ago, I started to face with selespeed problems again.

I leave the car in 1st gear, and when I come back few hours later I see it dropped to N, sometimes. Then I start the car and it jerks heavily and car stops. But next start is ok.

And another problem, it skips odd gears sometimes especially the times when it drops to N when car is parked.

Is there anybody faced with these problems actually the first one?
zhankal is offline  
Sponsored Links
Status: biased alfisti
AO Member
eivindcl's Avatar
Join Date: Feb 2011
Location: Norway
County: -
Posts: 365
ever calibrated your clutch?

have your clutch done many miles? it might be done..

checked oil level selespeed system?

head for your nearest dealer and hook the car up to the computer to see if there are any fault codes stored, and do the clutch self-learn/bleed routine.
eivindcl is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
Better still is to have a codereader or software and cable for your laptop to check what error codes are present.
If the clutch is around 80K miles old, its on its way out
it can also be the accumulator..
But first check error codes !
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

problem , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome