147 oil under sump area - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 28-02-07 Thread Starter
Status: -
AO Member
Join Date: Jan 2007
Location: Berkshire
Posts: 145
147 oil under sump area

Hi Folks,

147, 12,000mls 2004
Oil leak, very slow drip around front lower R/H corner of sump.

Let me first say that there is no problem with the drainplug! The only reason drainplug threads strip, is because some gorilla with a 1/2" square ratchet, with a peace of scaffolding on the end over does it!
( Use a 1/4 ratchet and tighten it as much as you like)

I have changed the seal behind the oil filter housing (not the filter). No difference!

Resealed the gasketless sump. Note: this is a R/H driveshaft out job, plus most of the O/S suspension to make space for withdrawal.
No difference!

Next job, (not done yet) replace the front crank seal and the cover plate gasket that it sits in. This involves disturbing the timing belt to gain access but as three years are nearly up, it's belt change anyway.

Anyone had similar experiences?

alfakid is offline  
Sponsored Links
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: 147 oil under sump area

Front crank seal should be fairly straightforward I would of thought, if that is indeed what it is. Rear main seal, thats more of a pig I reckon!
zulu ferret is offline  
(Post Link) post #3 of 4 Old 28-02-07 Thread Starter
Status: -
AO Member
Join Date: Jan 2007
Location: Berkshire
Posts: 145
Re: 147 oil under sump area

It's a process of elmination. To start with the oil appeared to be coming down from the filter housing. So one thing at a time. having stripped the car to the sump and not stopped the leak, the front area is the next best thing.

Also oil around rubber bits isn't clever ie wishbone bushes and timing belt. I WILL fix it!

alfakid is offline  
Status: motor control system failure ! help
AO Member
sanvir's Avatar
Join Date: May 2010
Location: South Africa
County: KwaZulu-Natal
Posts: 36

Member car:

alfa 147

hi guys i sent my car in to a mechanic to change rear main seal. he didnt do a good job , its still leaking.....jus wondering if i could use 1 of those products that stop oil leaks...is it good or bad to fill that in the engine
sanvir is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , area , oil , sump

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome