Electric antics (Remote & engine cut off) - GT 2007 3.2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 03-08-14 Thread Starter
Status: -
Join Date: May 2012
Location: Australia
County: Victoria
Posts: 1

Member car:


Electric antics (Remote & engine cut off) - GT 2007 3.2

Hi team

Went to use the remote to get into the car but didn't get any response. Tried 6 times over 10min until it the lights finally flashed and central locking unlocked. I wouldn't be concerned except for a couple of odd things:

Despite the alarm never having beeped when opening/closing it now beeps each time - odd. Plus the stereo asked for the security PIN code.

Any clues?

Something that may or may not be related. For a year now the car will every couple of weeks or so, while sitting at the lights all of the electrics cut out everything goes off like turning off the ignition) for a second and shuts off the engine. Luckily it starts immediately afterwards and runs without fault.

Sound familiar to anyone?
Parkpre is offline  
Sponsored Links
Status: Rupert Gaylord Egger of Eggington Hall
AO Gold Member
rugbymike7's Avatar
Join Date: Jan 2014
Location: United Kingdom
County: Hampshire
Posts: 6,919
Sounds battery related to me. If it's asked for your radio code then it has died a some point or maybe a dodgy connection/earth. Check your battery terminals are clean and tight would be my first check. Then check your battery voltage.
rugbymike7 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

2007 , antics , cut , electric , engine , remote

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome