yet another problem (part 2) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-02-07 Thread Starter
Status: -
AO Member
Join Date: Dec 2004
Posts: 16

Member car:

156 ts veloce

yet another problem (part 2)

The story so far..engine (2.0 t/s) only ran for a short while then stopped..restarted ok after 15mins but only ran for a few mins etc..
diagnosis tdc/crank sensor ,sensor changed engine now runs but very rough,taken back to garage, back on the computer, fault code indicates temp sensor flty...
week before crank senor changed, radiator failed, rad changed(by same garage) since then temp gauge hardly gets off the stop(50'c)..only rises to 70 when stopped in traffic......
I ve seen some posts...themostat/rad both faulty but cancel each other out so temp gauge looks normal at 90'c I can accept that the thermostat may be goosed but could it affect the running of the engine ?..presume engine temp is monitored by the injection cpu the sensor on the stat housing looks like its knackered..
anyone recently changed a stat/ much do they cost.
This year car has had power steering pipes changed, new rad, new crank senor and still needs work......Funny, I still like the car, but I'm starting to feel like a can of petrol and a box of matches may be my next purchase !!
iniltous is offline  
Sponsored Links
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

Re: yet another problem (part 2)

Changing the thermostat isn`t that expensive for the part can be a DIY job easily enough. Now the rad is working well the thermostat problem will show up even more so it definately sounds like it needs changing.
Chris is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

part , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome