2005 GT wing mirrors don't work - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-07-14 Thread Starter
Status: -
Join Date: Jul 2014
Location: United Kingdom
County: Greater London
Posts: 1
2005 GT wing mirrors don't work

Well, the mirrors work perfectly, just as refelctive as a mirror should be in fact!

However the electric mechanism to adjust them appears to be inoperative. When I move the selector on the drivers side door from side to side and then press the arrows to move the selected mirror nothing happens. The selector makes a beep every time I press it but neither mirror moves at all.

Anybody have any experience of this? Can't find anything on the forum. Could it be a motor or linkage, perhaps a fuse?

I'm new on here by the way, so hello all! This is my second Alfa, after a horrendous first experience with an Alfa 156 basically bankrupting me as a young lad in the early 2000s. Must say the GT feels a million times better, but still has its little niggles!
sinbad182 is offline  
Sponsored Links
Status: -
AO Gold Member
Wezley's Avatar
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 11,402
Images: 27

Member car:

159 2.4 JTDm


No help. Mine work they just don't fold in
Wezley is offline  
Status: -
AO Member
Join Date: Apr 2011
Location: United Kingdom
County: South Yorkshire
Posts: 283

Member car:

GT 2.0 JTS

I'm sure you realise its only the glass that moves inside the mirror covering - not the casing itself - that you can fold manually to put them out of the way when parked for example (that's if the hinge hasn't seized up).

In the owner's manual I can only find one fuse listed related to the driver's door and nothing for the mirrors - so if the windows work I suppose it's not a fuse.

Have you checked out the multiplug that supplies power to the various door components through the door jamb? I'd try "making and breaking" that connector a few times and maybe using contact cleaner spray on the pins and sockets (maybe moisture has entered). The connecter (that black rubber and grey plastic thing) separates easily - if you raise the grey plastic clip the rubber portion slips off to reveal the contacts.
jonb.gt is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

2005 , mirrors , wing , work

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome