yet another problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 14-02-07 Thread Starter
Status: -
AO Member
Join Date: Dec 2004
Posts: 16

Member car:

156 ts veloce

yet another problem

Just had the tdc/crank sensor changed and now although the engine
doesnt stop when warm, its running as rough as a badgers ****.
I have to rev the balls off at the lights etc otherwise revs drop
and engine pick up 'stutters' (but doesnt stall)
Could the garage that changed the sensor have screwed something else up ?, I would have thought the sensor was a straight swap new
for old ,but with the old tdc sensor engine ran a lot better, just not
for very long !!
Im going to take car back but any idea what the problem may
be..kinda suspect gargage will deny new problem anything to do with
what they did !! so would like to be well informed.

Last edited by iniltous; 14-02-07 at 22:52.
iniltous is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2006
Posts: 148

Member car:


Re: yet another problem

if they done the tdc sensor behind the exuast cam gear then they could have easly mis-timed the engine. a quick check of manifold vacuum out reveal if it is or isnt..

other possiblitlies is that they changed the wrong sensor or lefted a wiring socket off.
makker is offline  
Status: -
AO Silver Member
Wrenched's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: Warwickshire
Posts: 1,807

Member car:

GTV 24v

Re: yet another problem

You mean they handed it back to you without a road test, or has it gone wrong again since leaving workshop??
Wrenched is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome