help please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-02-07 Thread Starter
Status: -
AO Member
bigphil's Avatar
Join Date: May 2006
Posts: 41

Member car:

156 sportwagon

Hmmm help please

Hi Guys
Dont come on very often being a travelling man, sad tale of woe for my beautiful Alfa, after using copious amounts of oil sing buying it, it finally ended in engine meltdown, it went straight to W.A.D. wolverhampton (cant speak highly enough of them) since going there I have used vertualy no oil in 1000 miles. I had a 155 service car off them, and by god did it go, as soon as you touched the throttle the enginge is reving immediately and ready to go. I t has an edge to it "my problem is my 156 doesnt have that edge" although at 3000 rpm it starts to motor. So I am thinking its MAF problem, have seen them on ebay for 40, question is are they worth buying or will I be throwing money away. After all the problems getting the suspension, brakes, engine done I STILL LOVE IT.

if at first you d'ont suceed, skydiving is not for you
bigphil is offline  
Sponsored Links
Status: -
AO Member
robf781's Avatar
Join Date: Oct 2006
Location: Leeds
Posts: 820

Member car:

Alfa Spider

Re: help please

When the maf fails you usually get no performance at high revs, not
t'other way round. The twinspark is known for being more responsive at high revs, try driving it in the higher rev range to see if this is better. My wife never goes above 4000 revs in the 156 and so doesn't appreciate it as much as I do.
robf781 is offline  
Status: -
AO Platinum Member
Roswell's Avatar
Join Date: Mar 2004
Location: United Kingdom
County: Durham
Posts: 33,630
Images: 15
Re: help please

If you suspect MAF problems try unplugging it and going for a blast down the road. If there's an improvement then the MAF is goosed. If not, then its not.
Roswell is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome