156 heated seat issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-02-07 Thread Starter
Status: -
AO Member
Smic's Avatar
Join Date: Feb 2007
Location: Latvia
Posts: 15
Images: 2

Member car:

156 2.4 10v JTD

Warning 156 heated seat issue


My 156 (1999) is equipped with heated front seats... which are not working very well.. actually I think they do not work at all.

Now I have -20 in the thermometer outside the window, and everyone, who have lather seats in their car knows, how unpleasent it is to sit on them in such cold.

When I turn on the seat heating with the switch under the seat - red lights in the sides turns on - so I think the problem is not in the fuse box.

Maybe someone have had this kind of problem and have solved it?
Smic is offline  
Sponsored Links
Status: -
Join Date: Jul 2006
Location: Helsinki, Finland
Posts: 3

Member car:

156 1.8

Re: 156 heated seat issue


I noticed a similar problem with my 156 seats in that I couldnt feel the heat even this week at -15/20.

I decided to test the seat by starting the car from cold, switching on seat heating but switching off all other heaters. I then cleared the ice + snow from the car while wearing a t-shirt.... then I sat in the car.

I found that the seat was warm now after 5 minutes considering the car had been outside at -28 all night.

I then put my jacket on and couldnt feel any warmth!

So my idea is that the power or element to the seat just isn't suitable for such low temp's especially when I compare it to my last VW which almost burnt after a while!

Sorry to be no direct help for fixing but this is how I tested my (non-leather) seats out.

Good luck!
Dags is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , heated , issue , seat

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome