Suspension - possible issue help please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-07-14 Thread Starter
Status: Wheres the sun gone? :/
AO Member
Kris.P's Avatar
Join Date: Oct 2009
Location: United Kingdom
County: Pembrokeshire
Posts: 58
Suspension - possible issue help please

Hi guys,

I just need some opinions, i have had my GT laser tracked front and rear within the last couple of weeks, reason for was that there was some feathering on the n/s/f tyre but the car was pulling straight.

So the guys stuck it on the ramp and it was out a mile so they sorted that out and then the car was all over the place so i took it back and they checked the back which was also a mile out so they sorted the rear and re-tracked the front again and according to their kit it is all perfect now but the car is pulling into the center of the road when i put my foot down a little.

I can't really blame them as i was there watching everything they were doing so they couldn't lie to me and to be fair to them they stuck it back on and checked it again a couple of times after a few drives and what not.

What we did notice is that on the near side both front and rear is that there is a four and a bit finger gap between the arch and tyre where as on the offside there is only a 3 finger gap for both front and rear. Could this be the problem?

I know to a 156 2.0ts that i could get the suspension off but would it be any good for my GT 1.9?

Any opinions/knowledge on this would be great!


First a 156 2.0 Now a GT 1.9 JTDm... Ahhh a thing of beauty
Kris.P is offline  
Sponsored Links
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
156 bits are pretty interchangeable, there may be differences in springs though, so check the coloured marks are the same, and the ARBs IIRC are hollow on the GT but solid on the 156, but thinks like links, arms etc etc are the same.

On to the causes, was it a 4 wheel laser alignment? These places give a read out with camber and castor angles on etc etc so you can see how equal everything is.

purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

issue , suspension , tracking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome