2.4 JTD shudder - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-07-14 Thread Starter
Status: -
AO Member
Join Date: May 2008
Location: Long Preston
Posts: 137
2.4 JTD shudder

Have noticed the engine seems to shudder on start up like its moving about too much, the garage pointed it out last visit and suspected a weak engine mounting - when the engine is held around 900 rpm it feels very uneven almost as if its missing slightly, other than this it runs perfectly. I this a fault or a characteristic of the 5 cylinder engine? or could it be the reason behind the shuddering?
longprest is offline  
Sponsored Links
Status: dogging
AO Silver Member
Join Date: Jul 2012
Location: United Kingdom
County: Bristol
Posts: 1,375

Member car:

156 Sport 2005

I think you've answered your own question a shot mount can cause a shudder on startup. Replace the mount, it needs doing anyway, and go from there.

diddums100 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jtd , shudder

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome