What have you done to your Alfa 147/156/GT today? - Page 8 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 1173Likes
Reply
 
Thread Tools Search this Thread
Status: -
AO Silver Member
 
t3yls's Avatar
 
Join Date: Aug 2007
Location: Manchester
Posts: 2,813
Images: 4

Member car:

Alfa GT Jtdm

Quote:
Originally Posted by ALFADOIT View Post
Well gave my recently chassis fettled cloverleaf a real testing session on some great sussex back roads the last few days. Simply awesome, could not be happier, the poise of the car is sublime, and so much superior to my old GT on koni fsd's and eibach. Before i left on the trip i adjusted my ride height, went a bit lower all round. Was a little anxious that i would ruin the ride quality. Still the eibach pro kit was compliant and cosseting on the back roads, and dynamically first class. Cannot say enough positive things about the kit. Have found the perfect ride height now. And she looks and sits just lovely. Happy days.

Damien.
got a link to the kit? I've got the springs, but can't find the spring and damper set on internet
t3yls is online now  
Sponsored Links
Advertisement
 
(Post Link) post #177 of 2909 Old 09-08-14 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Quote:
Originally Posted by t3yls View Post
got a link to the kit? I've got the springs, but can't find the spring and damper set on internet
No worries t3yls here it is...

Damien.


Eibach Pro Street S Coilover Suspension Kit - Autolusso New Alfa Romeo Parts
ALFADOIT is offline  
Status: -
AO Silver Member
 
Jiberson1's Avatar
 
Join Date: May 2014
Location: United Kingdom
County: West Yorkshire
Posts: 1,591
Images: 1
Fitted some new egr gaskets and found out what the noise of something falling off my car was on the last outing, turns out I only have 3 bolts to hold it to the manifold now.
Jiberson1 is offline  
Status: -
AO Silver Member
 
t3yls's Avatar
 
Join Date: Aug 2007
Location: Manchester
Posts: 2,813
Images: 4

Member car:

Alfa GT Jtdm

Quote:
Originally Posted by ALFADOIT View Post
No worries t3yls here it is...
cheers

I knew there was a reason I only bought the springs
t3yls is online now  
Status: -
AO Silver Member
 
Jiberson1's Avatar
 
Join Date: May 2014
Location: United Kingdom
County: West Yorkshire
Posts: 1,591
Images: 1
Also just soldered a new connector on my abs sensor, see if it keeps throwing up errors now!
Jiberson1 is offline  
(Post Link) post #181 of 2909 Old 09-08-14 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Quote:
Originally Posted by t3yls View Post
cheers

I knew there was a reason I only bought the springs
Well worth it though, i spent a fortune on bilstein pss9's on my last project on my audi, and they were not as decent a ride quality..And noisy after 20k miles of use. I swore i would never have another coilover kit on a road car. Really grateful for Ned at autolusso for suggesting this kit for me. Could not be happier.

Also t3yls, i used Autolusso's special order front springs..Much better front ride quality and control than original kit springs.

Damien.
ALFADOIT is offline  
Status: still excited(shoudn't be)
AO Gold Member
 
ARnovice's Avatar
 
Join Date: Dec 2013
Location: The land of burning...
County: Berkshire
Posts: 7,874
Images: 3
1. changed pollen filter and treated ventilation system with one of those comma aircon bombs
2. Cleaned door sound system connector with Maplin connector cleaners
3. used some waxed tooth floss to eliminate clanking when open doors.
4. Found a reason for my driving seat being wobbly. Looks like I need to buy a seat in any condition for reasonable price...
ARnovice is offline  
(Post Link) post #183 of 2909 Old 12-08-14 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Fitted my new black repeaters and wound the coils down another thread.

Damien.

Last edited by ALFADOIT; 02-10-14 at 11:15.
ALFADOIT is offline  
Status: TJR Valeting
AO Silver Member
 
Tommywho156's Avatar
 
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 2,267
Quote:
Originally Posted by ALFADOIT View Post
Fitted my new black repeaters and wound the coils down another thread.

Damien.
I like those black repeaters Damien. Do you have a link to where you got them?
Tommywho156 is offline  
(Post Link) post #185 of 2909 Old 12-08-14 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Quote:
Originally Posted by Tommywho156 View Post
I like those black repeaters Damien. Do you have a link to where you got them?
Sure Tommy...

Blinker im Fiat Tuning Teile + Zubehör Shop von MW Motorsport

Damien.
ALFADOIT is offline  
Status: TJR Valeting
AO Silver Member
 
Tommywho156's Avatar
 
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 2,267
Quote:
Originally Posted by ALFADOIT View Post
Cheers mate....

I'll order a pair in the morning.
Tommywho156 is offline  
(Post Link) post #187 of 2909 Old 13-08-14 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

So went back to Platinum alloy wheel refurbishment his morning to have my wheels rebalanced, as i was experiencing steering vibration at around 70mph. As always the lads were brilliant. And got a tour of their refurbishment process. Anyhow now all is righteous, no more wheel vibration..phew..And fitted my 5mm front spacers again. And tried her new Italian clover wheel centre badges. Really like them. And finally her killer stance is resumed. Especially after lowering her again yesterday one thread all round. Happy days getting there now.

Damien.

Last edited by ALFADOIT; 02-10-14 at 11:15.
ALFADOIT is offline  
Status: Breraless :(
AO Platinum Member
 
Squadrone Rosso's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,906
Images: 45
Got ours back from service, ready for Holland next week.

A couple of unresolved issues though

Aircon drain hose making the passenger side footwell wet, exhaust manifold gasket ticks for about 15 secs after cold start & they couldn't re-set the service indicator, even with examiner
Squadrone Rosso is offline  
(Post Link) post #189 of 2909 Old 13-08-14 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Quote:
Originally Posted by Squadrone Rosso View Post
Got ours back from service, ready for Holland next week.

A couple of unresolved issues though

Aircon drain hose making the passenger side footwell wet, exhaust manifold gasket ticks for about 15 secs after cold start & they couldn't re-set the service indicator, even with examiner
Geez not good.. So new manifold gasket needed? Hope you have a great trip to holland. Look forward to the pictures. the dutch have some lovely Alfa's.

Damien.
ALFADOIT is offline  
Status: Breraless :(
AO Platinum Member
 
Squadrone Rosso's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,906
Images: 45
Quote:
Originally Posted by ALFADOIT View Post
Geez not good.. So new manifold gasket needed? Hope you have a great trip to holland. Look forward to the pictures. the dutch have some lovely Alfa's.

Damien.
The engine was "new" last year. It seals after 10 - 15 seconds as soon as it heats up. It's a tick tick tick noise. 90% sure it's the front set so hopefully easy to sort.

Can't take it back to AL as simply too far / no time post relocation.
Squadrone Rosso is offline  
Status: Always working
Identity Confirmed
Authorised Trader
 
Autolusso's Avatar
 
Join Date: Feb 2007
Location: United Kingdom
County: Bedfordshire
Posts: 6,303
Images: 222
Quote:
Originally Posted by Squadrone Rosso View Post
The engine was "new" last year. It seals after 10 - 15 seconds as soon as it heats up. It's a tick tick tick noise. 90% sure it's the front set so hopefully easy to sort.

Can't take it back to AL as simply too far / no time post relocation.
Sounds like a crack in the exhaust manifold rather than gasket, gasket would do it all the time not just on start up, won't cause and problem and if it is a front one it is easy, rear is engine out

Happy to help with it

Ned
Autolusso is offline  
Status: Breraless :(
AO Platinum Member
 
Squadrone Rosso's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,906
Images: 45
Quote:
Originally Posted by Autolusso View Post
Sounds like a crack in the exhaust manifold rather than gasket, gasket would do it all the time not just on start up, won't cause and problem and if it is a front one it is easy, rear is engine out

Happy to help with it

Ned
Cheers Ned
Squadrone Rosso is offline  
Status: -
AO Silver Member
 
Jiberson1's Avatar
 
Join Date: May 2014
Location: United Kingdom
County: West Yorkshire
Posts: 1,591
Images: 1
Changed top and bottom wishbones and drop link on drivers side of my GT, passenger side to do tomorrow. I'm sure you can probably guess the bit that caused the most pain and an extra 2 hours effort.
Jiberson1 is offline  
(Post Link) post #194 of 2909 Old 16-08-14 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Quote:
Originally Posted by Jiberson1 View Post
Changed top and bottom wishbones and drop link on drivers side of my GT, passenger side to do tomorrow. I'm sure you can probably guess the bit that caused the most pain and an extra 2 hours effort.
Good luck James mate.

Damien.
ALFADOIT is offline  
Status: -
AO Silver Member
 
Jiberson1's Avatar
 
Join Date: May 2014
Location: United Kingdom
County: West Yorkshire
Posts: 1,591
Images: 1
Quote:
Originally Posted by ALFADOIT View Post
Good luck James mate.

Damien.
Cheers Damien, know where I'm going next time so should probably be easier.
Can see the previous owner had put nice eBay crap on which actually is a pig to remove.
Jiberson1 is offline  
Status: pimping my ride...
AO Member
 
alex156jtd's Avatar
 
Join Date: Aug 2013
Location: United Kingdom
County: Surrey
Posts: 78
Fitted parking sensors , started to build the top of the dash tablet thing.
Few weeks ago fitted 18" rims with new tyre (rims could do with some refurbishing )
Month ago fitted some new speakers and change the timing belt plus w pump
6 weeks ago fitted new front seats (old ones was broken)
A while back I fitted hid on both meeting and high beam
When I bought it new clutch , changed gear box oil
Had to do some catch up
alex156jtd is offline  
Status: -
AO Member
 
Join Date: Aug 2014
Location: United Kingdom
County: Greater Manchester
Posts: 43

Member car:

147

Over the last two days Ive managed to sort out the wet dog stench in my 147. It turned out to be the aircon system so I changed the pollen filter but before I fitted the new one, I ran an aircon cleaning bomb which sorted the smell out a treat.

I also fitted a new Kenwood head unit and surround.

Gave the K&N induction kit that the previous owner fitted a clean and changed the engine oil and filter.

I also cleaned and conditioned the seats with Gliptone cleaner and conditioner. Finally I fitted a HID light kit. 6000k bulbs so not too chavvy...
kungfualfa is offline  
Status: OEM++
AO Silver Member
 
Egon's Avatar
 
Join Date: Jan 2012
Location: United Kingdom
County: Kent
Posts: 2,012
Images: 2

Member car:

147ts plus bits

Today i have utterly enjoyed driving my lil' 147.
She made me smile on a very bad day.
Egon is offline  
Status: Breraless :(
AO Platinum Member
 
Squadrone Rosso's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,906
Images: 45
Driven it 498 miles from home in South Wales to Zaandam near Amsterdam where we're staying for 5 nights

Seats aren't as good long distance as my Brera's or the Spider though.
Squadrone Rosso is offline  
Status: Back to 147 Owner
AO Member
 
KBR1's Avatar
 
Join Date: May 2003
Location: Birmingham
County: West Midlands
Posts: 897
Images: 5
Garage

Member car:

147 Q2 Sport

Chased dealership about clutch repair under warranty, missing my 147
KBR1 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
156 , alfa , or gt , thread , today

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome