What have you done to your Alfa 147/156/GT today? - Page 45 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 1173Likes
Reply
 
Thread Tools Search this Thread
(Post Link) post #1101 of 2909 Old 14-05-15 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Picked up my GT from Autolusso after having her new GTA 330mm brake kit fitted. Very happy..

Bit more info on my build thread.

Damien.
Attached Images
File Type: jpg GTA B.jpg (31.7 KB, 21 views)
ALFADOIT is offline  
Sponsored Links
Advertisement
 
VO2Max
Status: - Update
Guest
 
Posts: n/a
Very nice!

With all that power, you need it!
 
VO2Max
Status: - Update
Guest
 
Posts: n/a
Quote:
Originally Posted by Jiberson1 View Post
Aluminium all the way, lighter and doesn't hang down as low.

Where may I get one, and for how much?
 
Status: -
AO Silver Member
 
Jiberson1's Avatar
 
Join Date: May 2014
Location: United Kingdom
County: West Yorkshire
Posts: 1,591
Images: 1
Jiberson1 is offline  
VO2Max
Status: - Update
Guest
 
Posts: n/a
Job jobbed! Thanks . I'd considered buying one of these before, so not too disgusted with myself for trashing the old one.

€161.50 (which is about 116.50) incl. VAT, p&p, aus Deutschland.

Not bad!
 
Status: still excited(shoudn't be)
AO Gold Member
 
ARnovice's Avatar
 
Join Date: Dec 2013
Location: The land of burning...
County: Berkshire
Posts: 7,872
Images: 3
Sealing two wheels that I got from refurbishment yesterday...
ARnovice is offline  
Status: TJR Valeting
AO Silver Member
 
Tommywho156's Avatar
 
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 2,267
Stripped the bumper off, removes the oil cooler ready to fit the AL/Mocal kit. While I was under the car I changed the air filter and cleaned/treated any rust.
I think a new intercooler bracket is next on my hit list.
Tommywho156 is offline  
Status: Flaps? What flaps?
AO Silver Member
 
_The_Editor_'s Avatar
 
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,232
Quote:
Originally Posted by Tommywho156 View Post
Stripped the bumper off, removes the oil cooler ready to fit the AL/Mocal kit. While I was under the car I changed the air filter and cleaned/treated any rust.
I think a new intercooler bracket is next on my hit list.
Sack off the side mounted intercooler, get a FMIC kit from JTD performance
Tommywho156 likes this.
_The_Editor_ is offline  
Status: -
AO Member
 
djs93's Avatar
 
Join Date: Apr 2013
Location: United Kingdom
County: Cheshire
Posts: 367
Garage

Member car:

Mito Cloverleaf

Today I fit the Xcarlink box behind my head unit, works really well and I managed to route the cable into where the little cigarette lighter cubby hole is without having to drill any holes or anything. Looks great! And the Xcarlink seems a good unit, works very well the only minor issue which doesn't bother me is that you need the volume slightly higher than you would when listening to radio/CD. Overall very happy. Now onto trying to polish up the pedals, if not a new set is needed
Attached Images
File Type: jpg image_1431784821552.jpg (61.3 KB, 14 views)
File Type: jpg image_1431784852366.jpg (74.3 KB, 16 views)
Wezley likes this.
djs93 is offline  
Status: 147 DC,
AO Member
 
2tone's Avatar
 
Join Date: Jul 2009
Location: United Kingdom
County: Buckinghamshire
Posts: 78
Garage

Member car:

147 DC

just got car back from autolusso after inlet manifold flap removal and ecu delete, few quid lighter but should save the engine from destruction ?
Autolusso and AutolussoNorth like this.
2tone is offline  
Status: Flaps? What flaps?
AO Silver Member
 
_The_Editor_'s Avatar
 
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,232
Removed my MAF sensor for a clean today.. Been meaning to pop it out for a while... Damned fiddly job mind! Good thing I did too, found some smashed up insect parts stuck in the grill so it looks like some dirt has got through to it!

Had a good look at the airbox and associated pipework but couldn't see any splits/holes that would let unfiltered air through... Will pop it out again in a few months and see how it looks.

Had a poke about at the VNT pipework as well to check over for general wear and tear.. Looks OK as far as I saw, but the solenoid mounted under the MAF unit is pretty oily! 99% certain it was from when I blew my lower turbo hose of and sprayed that side of the engine bay with oil from the turbo!

Quote:
Originally Posted by 2tone View Post
just got car back from autolusso after inlet manifold flap removal and ecu delete, few quid lighter but should save the engine from destruction ?
I assume you meant EGR delete, engines tend not to run so well without the ECU

_The_Editor_ is offline  
Status: Just starting out...
AO Member
 
RomeoDone's Avatar
 
Join Date: May 2015
County: -
Posts: 27
Images: 2
Garage
Started out the day de-badging my 147 and finished off adding a new Sony BT stereo...couple of bits to iron out on the Stereo 1) Wiring needs sorting as not holding memory 2) Waiting for postie to deliver the fascia
RomeoDone is offline  
Status: Oily inlet...
Club Member
Membro Premio
 
baxter2308's Avatar
 
Club Member Number: 2209
Join Date: Feb 2013
Location: United Kingdom
County: North Yorkshire
Posts: 864
Garage

Member car:

147 Sport Q2

Quote:
Originally Posted by _The_Editor_ View Post
I assume you meant EGR delete, engines tend not to run so well without the ECU
baxter2308 is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,322
Images: 12
Garage
Washed, then Meg's 3 stage clean, polish and wax. Hoovered out interior and leaves under bonnet hiding behind rubber pieces and under boot lid.

Shiny!!
gazza82 is offline  
Status: Just starting out...
AO Member
 
RomeoDone's Avatar
 
Join Date: May 2015
County: -
Posts: 27
Images: 2
Garage
Painted Calipers & Finished Stereo Install

Went with the majority who suggested red brake calipers and they turned out great (see attached image).

Also sorted out the wiring on my new stereo and added the aerial adapter...blew a fuse but sorted after a trip to Halfords.

All in all a successful day
Attached Images
File Type: jpg image.jpg (75.9 KB, 11 views)
RomeoDone is offline  
(Post Link) post #1116 of 2909 Old 17-05-15 Thread Starter
Status: GT clover 170 Q2 called SOOTY.:-)
Club Member
Membro Premio
 
ALFADOIT's Avatar
 
Join Date: Mar 2008
Posts: 2,199
Images: 12

Member car:

GT.Clover 170 Q2

Quote:
Originally Posted by _The_Editor_ View Post
Sack off the side mounted intercooler, get a FMIC kit from JTD performance
Tom you should do this..

Damien.
ALFADOIT is offline  
Status: -
AO Member
 
Join Date: Aug 2009
Location: United Kingdom
County: Essex
Posts: 48
Upper wishbone replacement, peace and quiet.
chris432626 is offline  
Status: The Rosso twins are here!
Club Member
Membro Premio
 
edraven71's Avatar
 
Club Member Number: 1612
Join Date: Oct 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 3,674
Garage
Quote:
Originally Posted by VO2Max View Post
Job jobbed! Thanks . I'd considered buying one of these before, so not too disgusted with myself for trashing the old one.

161.50 (which is about 116.50) incl. VAT, p&p, aus Deutschland.

Not bad!
Had one of those and it was good, but would recommend this one Alfa 147 Engine Tuning Aluminium Bundskjold

My Alfisti one split at the rear bends after a year and also pitted very badly, the Alfastumper one has been on two years now and is like new.
edraven71 is offline  
Status: TJR Valeting
AO Silver Member
 
Tommywho156's Avatar
 
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 2,267
Quote:
Originally Posted by ALFADOIT View Post
Tom you should do this..

Damien.
That's one of my plans for the future once the maintenance bits are out the way.
Tommywho156 is offline  
VO2Max
Status: - Update
Guest
 
Posts: n/a
Too late, already bought it!

I'll have to let you know how I get on!
 
Status: Flaps? What flaps?
AO Silver Member
 
_The_Editor_'s Avatar
 
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,232
First proper drive today after cleaning my MAF sensor.... First impressions are very good!

Overall feels more responsive and linear which is nice! Also seems to be indicating better fuel economy...

Previously the dash display was rock steady at 60mpg over about 3k miles, though fuel receipts and odo readings returned 50mpg on the dot.. Since the remap there's been a 10mpg discrepancy between the two...

Average MPG on the dash computer for my 80 mile trip this morning was 66 mpg, which will hopefully turn out to be around 54-56mpg on my next fill up

Will have to see how it settles down this week!
_The_Editor_ is offline  
Status: -
AO Gold Member
 
Wezley's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 11,457
Images: 27
Garage

Member car:

159 2.4 JTDm

Quote:
Originally Posted by djs93 View Post
Today I fit the Xcarlink box behind my head unit, works really well and I managed to route the cable into where the little cigarette lighter cubby hole is without having to drill any holes or anything. Looks great! And the Xcarlink seems a good unit, works very well the only minor issue which doesn't bother me is that you need the volume slightly higher than you would when listening to radio/CD. Overall very happy. Now onto trying to polish up the pedals, if not a new set is needed
I have a Motorola (think it is) link. I just plugged mine into the lead that went into the CD mulitiplayer. The iPod just sits behind the pull down armrest.
No problem really as I can control it (to a point) from the head unit but what I have noticed is that it does not seem to charge the rather old iPod. Instead every few days I have to charge it.

Does yours charge your iPod? I would not mind but this link was about 50 and I know with IOS updates devices that once charged sometimes after an update no longer charge but this is as mentioned a 1st Gen Touch which does not update now.

Priorities I find, are usually someone else's.
Statements above are all my own opinion and not fact.
Wezley is offline  
Status: midlife crisis
Newbie
 
Join Date: May 2015
Location: Ireland
County: -
Posts: 9
Garage
Squealing rear brake has been bugging me for a week.
New discs and pads 2 weeks ago, wound back calipers properly and guide pins were lovely and free.Handbrake adjusted so that levers on calipers returned to stops, filed a chamfer on the pads, and a dab of copper grease onto contact points of pads....still squealed.

took off pad guides today, and polished with scotchpad.
A quick 40 mile blast, and not a sound off it.

This GT appears to like a bit of attention.
tyney is offline  
Status: Back in the fold!
AO Member
 
manails's Avatar
 
Join Date: Mar 2008
Location: Ireland
County: Donegal
Posts: 279

Member car:

GT Blackline

Quote:
Originally Posted by MalcQV View Post
I have a Motorola (think it is) link. I just plugged mine into the lead that went into the CD mulitiplayer. The iPod just sits behind the pull down armrest.
No problem really as I can control it (to a point) from the head unit but what I have noticed is that it does not seem to charge the rather old iPod. Instead every few days I have to charge it.

Does yours charge your iPod? I would not mind but this link was about 50 and I know with IOS updates devices that once charged sometimes after an update no longer charge but this is as mentioned a 1st Gen Touch which does not update now.

I've got an xcar link in mine with first get ipod touch and it charges, think it was a bit more than 50 though....
Wezley likes this.
manails is offline  
Status: -
AO Member
 
djs93's Avatar
 
Join Date: Apr 2013
Location: United Kingdom
County: Cheshire
Posts: 367
Garage

Member car:

Mito Cloverleaf

Quote:
Originally Posted by MalcQV View Post
I have a Motorola (think it is) link. I just plugged mine into the lead that went into the CD mulitiplayer. The iPod just sits behind the pull down armrest.
No problem really as I can control it (to a point) from the head unit but what I have noticed is that it does not seem to charge the rather old iPod. Instead every few days I have to charge it.

Does yours charge your iPod? I would not mind but this link was about 50 and I know with IOS updates devices that once charged sometimes after an update no longer charge but this is as mentioned a 1st Gen Touch which does not update now.
Quote:
Originally Posted by manails View Post
I've got an xcar link in mine with first get ipod touch and it charges, think it was a bit more than 50 though....

The Xcarlink unit I installed charges both my iPhone 5, and ipod nano. It cost me 70 and you can see it here
http://www.ebay.co.uk/itm/2509669495...%3AMEBIDX%3AIT

If you read in the description it does say it has the ability to charge 1st gen Ipod Touch.
Wezley likes this.
djs93 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
156 , alfa , or gt , thread , today

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome