Alfa 156 Warning light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 20-01-07 Thread Starter
Status: -
Join Date: Jan 2007
Posts: 1
Idea Alfa 156 Warning light

Hi there

I have an Alfa 156 2.0 JTS manual. It has a fault whereby the "motor control system failure" warning light comes on - predictably about a minute after starting from cold, and it stays on for about a minute before disappearing again. It only comes on when starting from cold.

The local dealership are at a complete loss to diagnose the problem. Anyone have any ideas? Thanks
Gasman is offline  
Sponsored Links
Status: -
AO Member
m_j_ratter's Avatar
Join Date: Apr 2007
Location: Aberdeen
Posts: 64
Re: Alfa 156 Warning light

there is a thread on here from ian bird, he had the same prob and it was a duff battery, i am having the same issues now and will be checking my battery output before getting involved with any expensive main dealer or specialist diagnostic work
m_j_ratter is offline  
Status: - Update
Posts: n/a
Re: Alfa 156 Warning light

welcome to AO Gasman...

as mj said..its sounds like a knackered battery...


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , light , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome